1160-C语言实验——某年某月的天数-JAVA

C语言实验——某年某月的天数

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

输入年和月,判断该月有几天?


Input

输入年和月,格式为年\月。

Output

输出该月的天数。


Sample Input

2009\1

Sample Output

31

Hint

注意判断闰年啊


Source

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			String date = scanner.nextLine();
			String string = "\\\\";
			String[] s = date.split(string);
			int num = 0;
			int year = Integer.parseInt(s[0]), month = Integer.parseInt(s[1]);
			switch (month) {
			case 1:
			case 3:
			case 5:
			case 7:
			case 8:
			case 10:
			case 12:
				num = 31;
				break;
			case 4:
			case 6:
			case 9:
			case 11:
				num = 30;
				break;
			default:
				break;
			}
			if (year % 4 == 0 && year % 100 != 0 || year % 400 == 0) {
				if (month == 2) {
					num = 29;
				}
			}
			else {
				if (month == 2) {
					num = 28;
				}
			}
			System.out.println(num);
		}
	}
}

   还有一种做法,就是使用Calendar类,SimpleDateFormat类以及Date类。最近比较忙暂时不给出做法。

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值