Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3

注意(`・ω・´):这个题的解法是把矩阵本身当成一个图(即m*n的矩阵就对应一个m*n的图)

#include<cstdio>
#include<cstring>
const int MAXN=100+10;
char map[MAXN][MAXN];
int n,m;
void dfs(int x,int y)//深度优先搜索
{
    if(map[x][y]=='.')//如果没水或者已经遍历过了,就结束
        return ;
     map[x][y]='.';//标记为已遍历
    //递归(x,y)周围的八个点
     dfs(x+1,y+1);
     dfs(x,y+1);
     dfs(x-1,y+1);
     dfs(x-1,y);
     dfs(x-1,y-1);
     dfs(x,y-1);
     dfs(x+1,y-1);
     dfs(x+1,y);    
}
 
int main()
{
    while(~scanf(%d%d,&n,&m))
    {
        for(int i=1;i<=n;i++)//读入
            scanf(%s,map[i]+1);
     
        //在规定的图周围加上一圈,标记为没水,防止在DFS最外面一圈的时候越界
        //或者下面的两层循环的范围改成2~n-1也可以
        for(int i=0;i<=n+1;i++)
            map[i][0]=map[i][m+1]='.';
        for(int i=0;i<=m+1;i++)
            map[0][i]=map[n+1][i]='.';
 
        int ans=0;
        for(int i=0;i<=n+1;i++)
        {
            for(int j=0;j<=m+1;j++)
            {
                if(map[i][j]=='W') {
                    ans++;
                    dfs(i,j);
                }
            }
        }
        printf(%d,ans);
    }
 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值