Catch That Cow Time Limit: 2000 ms Memory Limit: 65536 KiB

19 篇文章 0 订阅

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。 
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

AC代码(一维数组的bfs)

#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <bits/stdc++.h>
using namespace std;
int vis[100000+10];
int nxt[3] = {1,-1};
struct node
{
    int x;
    int step;
}s, t;
int bfs(int n, int k)
{
    int i;
    queue<node> q;
    s.x = n, s.step = 0;
    q.push(s);
    vis[n] = 1;
    while(!q.empty())
    {
        s = q.front();
        q.pop();
        if(s.x==k)
            return s.step;
        for(i = 0;i<2;i++)
        {
            t.x = s.x+nxt[i];
            t.step = s.step+1;
            if(t.x>=0&&t.x<=100000&&!vis[t.x])
            {
                q.push(t);
                vis[t.x] = 1;
            }
        }
        t.x = s.x*2, t.step = s.step+1;
        if(t.x>=0&&t.x<=100000&&!vis[t.x])
        {
            q.push(t);
            vis[t.x] = 1;
        }
    }
    return 0;
}
int main()
{
    int n, k;
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        memset(vis, 0, sizeof(vis));
        printf("%d\n",bfs(n, k));
    }
    return 0;
}


/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 604KB
****************************************************/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值