HDU6446 Tree and Permutation(树上两点间距离)

Tree and Permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1204    Accepted Submission(s): 439


 

Problem Description

There are N vertices connected by N−1 edges, each edge has its own length.
The set { 1,2,3,…,N } contains a total of N! unique permutations, let’s say the i -th permutation is Pi and Pi,j is its j -th number.
For the i -th permutation, it can be a traverse sequence of the tree with N vertices, which means we can go from the Pi,1 -th vertex to the Pi,2 -th vertex by the shortest path, then go to the Pi,3 -th vertex ( also by the shortest path ) , and so on. Finally we’ll reach the Pi,N -th vertex, let’s define the total distance of this route as D(Pi) , so please calculate the sum of D(Pi) for all N! permutations.

 

 

Input

There are 10 test cases at most.
The first line of each test case contains one integer N ( 1≤N≤105 ) .
For the next N−1 lines, each line contains three integer X , Y and L , which means there is an edge between X -th vertex and Y -th of length L ( 1≤X,Y≤N,1≤L≤109 ) .

 

 

Output

For each test case, print the answer module 109+7 in one line.

 

 

Sample Input

 

3 1 2 1 2 3 1 3 1 2 1 1 3 2

 

 

Sample Output

 

16 24

 

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 

原博主https://blog.csdn.net/CURRYWANG97/article/details/82055814

做了一些小改动,其实可以结构体写.....但是我懒就没有写

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef long long ll;
const int maxn = 100000 + 10;
int a[maxn];
const ll mod = 1e9 + 7;
ll fac[maxn];
struct edge
{
    int to,next;
    ll w;
}e[maxn*2];
int head[maxn];
int tot;
int num[maxn];
ll dp[maxn];
ll ans;
void add(int u,int to,int w)
{
    e[++tot].next=head[u];
    e[tot].w=w;
    e[tot].to=to;
    head[u]=tot;
}
int n;
void dfs(int u,int fa)
{
    dp[u]=1;
    for(int i=head[u];i!=0;i=e[i].next)
    {
        int v=e[i].to;
        ll w=e[i].w;
        if(v==fa) continue;
        dfs(v,u);
        dp[u]+=dp[v];
        ans= (ans + dp[v]*(n-dp[v])%mod*w%mod)%mod;
    }
}
int main()
{

   
    while(~scanf("%d",&n))
    {
        tot=0;
        memset(head,0,sizeof(head));
        memset(dp,0,sizeof(dp));
        memset(num,0,sizeof(num));
        for(int i=0;i<n-1;i++)
        {
            int u,v;
            ll w;
            scanf("%d%d%lld",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }
        ans=0;
        dfs(1,0);
        ll now=1;
        for(int i=2;i<=n-1;i++)
        {
            now=now*i % mod;
        }
        ans=ans*2%mod*now%mod;
        printf("%lld\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值