POJ 1426 Find The Multiple 深搜广搜(信题目你就完了系列)

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43209 Accepted: 18144 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

道理很简单,BFS或者DFS

比如设置当前string代表当前值,那么下一个就是dfs(string+"1")或者dfs(string+"0") (此为伪代码,会意即可)

bfs也一样,之后判断string能否被n整除,同余模就ok(这里不懂的看代码就ok)

然后一想这么简单,就写吧

第一发bfs,提示MLE

行,那我换dfs来一发,出来个TLE

当时满脑黑线,随机跑了几个数据,发现有点不对劲,又去了discuss看了眼-------最高位也不超过19位数字!!!!!

换句话说题目中的最高200位数是骗人的,你要是信了题目的邪怎么写都过不去(╯>д<)╯⁽˙³˙⁾

于是改了一下,到20位return就好了

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
queue<string>q;
int n;
bool judge;
void dfs(string now,int len){
    int test=0;
    if(judge)
        return ;
    if(len==20)
        return ;
    for(int i=0;i<now.size();i++){
        test=(test*10+now[i]-'0')%n;
    }
    if(test==0){
        judge=true;
        cout<<now<<endl;
        return ;
    }
    string now1=now;
    now+="1",now1+="0";
    dfs(now,len+1);
    dfs(now1,len+1);
    
}
int main()
{
    std::ios::sync_with_stdio(false);
    while(cin>>n){
        if(n==0){
            break;
        }
        judge=false;
        string now="1";
        dfs(now,1);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值