Train Problem II hdu1023

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
 
 
1 2 3 10
 

Sample Output
 
 
1 2 5 16796
卡特兰数

#include <iostream>

#include <algorithm>
using namespace std;
int a[105][100];//ans[i][j] i表示第几个卡特兰数,
                  //j=0表示位数,j从1到ans[i][0]是个位数往上 
                  
void ktl()
{
a[1][0]=1; a[1][1]=1;
a[2][0]=1; a[2][1]=2;
int len=1,yu,t,i,j;
for( i=3;i<=104;i++)
   {
    yu=0;
    for(j=1;j<=len;j++) 
    {
  t=a[i-1][j]*(4*i-2)+yu;//注意先乘再加余数 
      a[i][j]=t%10;//这一位的值是对10取余 
       yu=t/10;//进位是除以10 
        }
        while(yu)
          {
          a[i][++len]=yu%10;
   yu/=10;
  }
for(j=len;j>=1;j--)
    {
    t=a[i][j]+yu*10;//除法先加“余数”再除 
      a[i][j]=t/(i+1);//留在这一位是除 
    yu=t%(i+1);//“余数”是取余
//除法和乘法是逆过程,计算时也是反过来 
 }  
while(!a[i][len])
    {
    len--;
 }  
a[i][0]=len;  
}
}
int main()
{
ktl();
int n;
while(~scanf("%d",&n))
     {
      for(int i=a[n][0];i>0;i--)
          printf("%d",a[n][i]);
          printf("\n");
 }
return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值