Labyrinth【树的直径+BFS】

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

 

题意:

题目让求的是链接一条‘.’所需要的最大绳索长度,就是去寻一条最长的'......'点即可。

思路

  一次bfs()求出始发节点,再加一次bfs()求出从该点出发所能到达的最远距离。

 

完整代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
typedef long long ll;
const int maxN=1005;
int dir[4][2]=
{
    -1,0,
    0,-1,
    1,0,
    0,1
};
int N, M, nx, ny;
char mp[maxN][maxN];
struct node
{
    int x, y, s;
    node(int a=0, int b=0, int c=0):x(a),y(b),s(c) {}
};
bool within(int x, int y) { return x>=1 && x<=M && y>=1 && y<=N; }
int bfs(int x, int y)
{
    int ans=0;
    bool vis[maxN][maxN];   memset(vis, false, sizeof(vis));
    queue<node> Q;
    Q.push(node(x, y, 0)); vis[x][y]=true;
    while(!Q.empty())
    {
        node u=Q.front();   Q.pop();
        for(int i=0; i<4; i++)
        {
            int xx=u.x+dir[i][0], yy=u.y+dir[i][1];
            if(!within(xx, yy) || mp[xx][yy]=='#' || vis[xx][yy]) continue;
            vis[xx][yy]=true;
            Q.push(node(xx, yy, u.s+1));
            if(ans < u.s+1)
            {
                ans=u.s+1;
                nx=xx;  ny=yy;
            }
        }
    }
    return ans;
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &N, &M);
        nx=ny=0;
        for(int i=1; i<=M; i++)
        {
            getchar();
            scanf("%s", mp[i]+1);
            for(int j=1; j<=N; j++)
            {
                if(mp[i][j] == '.') { nx=i; ny=j; }
            }
        }
        if(!nx || !ny) { printf("Maximum rope length is 0.\n"); continue; }
        int ans=0;
        for(int i=1; i<=2; i++) ans=max(ans, bfs(nx, ny));
        printf("Maximum rope length is %d.\n", ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值