1072 Gas Station (30分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.
Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.
Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.
Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

基本思路:对每个加油站用一次Dijkstra算法,更新dis[]数组,找出最小距离,并算出平均值和全局变量比较,并更新全局变量,最后按要求输出。

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1100;
const int inf = 10000000;
bool vis[maxn] = { false };
int g[maxn][maxn], dis[maxn], n, m, k, ds, minalldis = -1, minid;
double minallaverage = inf;
int str2id(string s) {
	int id = 0, temp;
	if (s[0] == 'G') {
		for (int i = 1; i < s.length(); i++) {
			temp = s[i] - '0';
			id = id * 10 + temp;
		}
		return id + n;
	}
	else 
		return stoi(s);
}
void Dijkstra(int index) {
	fill(dis, dis + maxn, inf);
	memset(vis, false, sizeof(vis));
	dis[index] = 0;
	for (int i = 1; i <= n+m; i++) {
		int u = -1, mindis = inf;
		for (int j = 1; j <= n+m; j++) {
			if (vis[j] == false && dis[j] < mindis) {
				mindis = dis[j];
				u = j;
			}
		}
		if (u == -1)
			return;
		vis[u] = true;
		for (int v = 1; v <= m + n; v++) {
			if (vis[v] == false && g[u][v] != inf) {
				if (dis[u] + g[u][v] < dis[v]) {
					dis[v] = dis[u] + g[u][v];
				}
			}
		}
	}
}

int main() {
	cin >> n >> m >> k >> ds;
	int distance, id1, id2;
	string s1, s2;
	fill(g[0], g[0] + maxn * maxn, inf);
	for (int i = 0; i < k; i++) {
		cin >> s1 >> s2 >> distance;
		id1 = str2id(s1);
		id2 = str2id(s2);
		g[id1][id2] = distance;
		g[id2][id1] = distance;
	}
	for (int i = 1; i <= m; i++) {
		double dis_average = 0;
		int mindistance = inf, flag = 0;
		Dijkstra(i + n);
		for (int i = 1; i <= n; i++) {
			if (dis[i] > ds) {
				flag = 1;
				break;
			}
			if (mindistance > dis[i]) {
				mindistance = dis[i];
			}
			dis_average += dis[i];
		}
		dis_average /= n;
		

		if (flag == 1)//有超出服务范围的点,不符合要求,直接pass
			continue;
		else {
			if (mindistance > minalldis) {
				minalldis = mindistance;
				minallaverage = dis_average;
				minid = i;
			}
			else if (mindistance == minalldis && dis_average < minallaverage) {
				minallaverage = dis_average;
				minid = i;
			}
		}
	}
	if (minalldis == -1)
		cout << "No Solution" << endl;
	else {
		cout << "G" << minid << endl;
		cout << fixed << setprecision(1) << (double)minalldis << " " << fixed << setprecision(1) << minallaverage << endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
05-28
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值