VRRP实验——虚拟路由冗余协议

VRRP协议

  • 在多个路由器之间运行
  • 可以虚拟出一个或多个网关地址(虚拟路由器)
  • 从而实现内网不同网段之间的互通

VRRP 的工作过程

  • 运行VRRP的多个路由器之间通过VRRP报文的交互,从而选择出一个最优的路由器,作为Master路由器,主路由器,以后就用这个设备转发数据包。
  • Master路由器仅仅只有一个,其他的路由器称之为backup路由器,备用
  • 同时,Master和backup路由器,会产生一个虚拟的路由器,也就是一个虚拟的IP地址。

实验拓扑

要求:PC1去往PC2时,走LSW1路径,当LSW1的1口故障时,走LSW2路径。PC2去往PC1时,走LSW2路径,当LSW2的1口故障时,走LSW1路径。利用了浮动路由实现了互相备份,但是故障不能出现在2口,当故障在2口,则浮动路由不能生效。PC1从 SW2走,但是从R1的g0/0/0口出(路由依旧为指向11.0.0.1的下一跳),无法到达PC2。
在这里插入图片描述
VRRP优先级,数值越大越优先。PC1:主LSW1时,优先级为120。备份在LSW2时,优先级为115。
PC2:主LSW2时,优先级为120。备份在LSW1时,优先级为115。

R1配置

配置完环回口地址和两个接口地址后,配置静态路由和浮动路由。

ip route-static 192.168.10.0 255.255.255.0 11.0.0.1
ip route-static 192.168.10.0 255.255.255.0 12.0.0.1 preference 70
ip route-static 192.168.20.0 255.255.255.0 12.0.0.1
ip route-static 192.168.20.0 255.255.255.0 11.0.0.1 preference 70

LSW1配置

vlan batch 10 20 100
interface Vlanif10
 ip address 192.168.10.10 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1
 vrrp vrid 1 priority 120
 vrrp vrid 1 track interface GigabitEthernet0/0/1
 vrrp vrid 1 track interface GigabitEthernet0/0/2
#
interface Vlanif20
 ip address 192.168.20.10 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1
 vrrp vrid 2 priority 115
#
interface Vlanif100
 ip address 11.0.0.1 255.255.255.252
interface GigabitEthernet0/0/1
 shutdown
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
ip route-static 0.0.0.0 0.0.0.0 11.0.0.2

最后一条为默认路由,指向所有网段,通过11.0.0.2下一跳。

LSW2配置

vlan batch 10 20 100
interface Vlanif10
 ip address 192.168.10.20 255.255.255.0
 vrrp vrid 1 virtual-ip 192.168.10.1
 vrrp vrid 1 priority 115
#
interface Vlanif20
 ip address 192.168.20.20 255.255.255.0
 vrrp vrid 2 virtual-ip 192.168.20.1
 vrrp vrid 2 priority 120
 vrrp vrid 2 track interface GigabitEthernet0/0/1
 vrrp vrid 2 track interface GigabitEthernet0/0/2
#
interface Vlanif100
 ip address 12.0.0.1 255.255.255.252
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
 #
ip route-static 0.0.0.0 0.0.0.0 12.0.0.2

LSW3配置

vlan batch 10 20
interface Ethernet0/0/1
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20

PC1的网关为192.168.10.1,PC2的网关为192.168.20.1

验证:正常情况下用PC1pingPC2,追踪路径如下图。

在这里插入图片描述

如图所示,走的是192.168.10.10,是LSW1上的路径。

关闭LSW1的g0/0/1接口,主用设备失效,走备用路径。

用PC1pingPC2,追踪路径如下图。

在这里插入图片描述

如图所示,走的是192.168.10.20,是LSW2上的路径。

©️2020 CSDN 皮肤主题: 创作都市 设计师:CSDN官方博客 返回首页