02-线性结构4 Pop Sequence (25 分)

 

02-线性结构4 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

才疏学浅,代码有不当的地方,望高手指点

#include<iostream>
#include<cstdlib>
#define ERROR 0
using namespace std;
typedef int position;
typedef int ElementType;
struct SNode
{
	ElementType *Data;
	position Top;
	int MaxSize;
};
typedef struct SNode *Stack; 
Stack CreateStack(int maxsize)
{
	Stack s;
	s=(Stack)malloc(sizeof (struct SNode));
	s->Data=(ElementType*)malloc(maxsize*sizeof (ElementType));
	s->MaxSize=maxsize;
	s->Top=-1;
	return s;
}
bool IsFull( Stack S )
{
    return (S->Top == S->MaxSize-1);
}
 
bool Push( Stack S, ElementType X )
{
    if ( IsFull(S) ) {
        //printf("堆栈满");
        return false;
    }
    else {
        S->Data[++(S->Top)] = X;
        return true;
    }
}
 
bool IsEmpty( Stack S )
{
    return (S->Top == -1);
}
 
ElementType Pop( Stack S )
{
    if ( IsEmpty(S) ) {
        //printf("堆栈空");
        return ERROR; /* ERROR是ElementType的特殊值,标志错误 */
    }
    else 
        return ( S->Data[(S->Top)--] );
}
ElementType findtop( Stack S )
{
	if(IsEmpty(S))
	{
		return ERROR; 
	}
	else return S->Data[S->Top];
}
int main()
{
	int M,N,K,a[100000];
	cin>>M>>N>>K;
	
	
	while(K--)
	{
		Stack s=CreateStack(M);
		int n=1;
		for(int i=1;i<=N;i++)
		{
			cin>>a[i];
		}
		int i=1,popelem,t=1;
		while(i<=N)
		{
			if(!IsEmpty(s))
			{
				popelem=findtop(s);
				if(popelem==a[i])
				{
					
					popelem=Pop(s);
					i++;
					continue;
				}
			}
			if(n>N)
			{
				t=0;
				break;
			}
			if(!Push(s,n))
			{
				t=0;
				break;
			}
			//判断能否入栈 
			if(n==a[i])
			{
				popelem=Pop(s);
				i++;	
			}
			n++;	
		}
		if(!t)cout<<"NO"<<endl;
		else cout<<"YES"<<endl;
	
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值