You are using pip version 19.1.1, however version 19.2.1 is available类问题解决方法

准备用Python爬虫,之前都是用强大的VS写python代码,毕竟不如专业的好用,果断用起了PyCharm,看似简单的东西,总能将你折磨到底。这不,刚刚下载一个模块时(requests),就出现了一些问题,那就按照命令行中提示的命令做呗,但是当在命令行中敲入它所提示的:pip install requests时,它告诉我pip的版本不合适,需要更新升级,且告诉我应该用这个命令去更新升级pip:“python -m pip install --upgrade pip”,但是当你敲入这个命令后,得到的结果依然是不行,上图吧我还是。

可见这个提示不起作用,我找了很多资料说的都是乱七八糟的,还解决不了,现在我自己解决了,所以分享出来,供大家参考,希望帮到各位!少走弯路!

只要在“python -m pip install --upgrade pip“后加上--user,这个问题就能解决,即“python -m pip install --upgrade pip --user”。下面上图:  ↵

喜欢编程的朋友、欢迎探讨,一起学习、上面有很多资源供大家使用,欢迎关注我的微信公众号:“软件编程网站开发”!

发布了23 篇原创文章 · 获赞 29 · 访问量 2万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览