1007 Maximum Subsequence Sum

题目
Given a sequence of K integers { N​1, N​2, …, N​K}. A continuous subsequence is defined to be { N
​i, N​i+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

题目意思
给你一个数组,问这个数组组成的所有子串中,哪个子串的和最大,输出这个和,并且输出这个子串的第一个数和最后一个数。

特殊情况

  • 当整个数组全是负数的情况下,输出0和数组的第一个数和最后一个数。
  • 至少有一个数为0,其他为负数时,输出0 0 0.

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>

using namespace std;

long long int sum=-999999999,num;

int main()
{
    int n,hx[10003],flag=0;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&hx[i]);
        if(hx[i]<0)
            flag++;
    }
    if(flag==n)
    {
        printf("0 %d %d\n",hx[0],hx[n-1]);
    }
    else
    {
        int start,End;
        for(int i=0; i<n; i++)
        {
            num=0;
            for(int j=i; j<n; j++)
            {
                num =num+hx[j];
                if(num>sum)
                {
                    sum=num;
                    start=hx[i];
                    End=hx[j];
                }
            }
        }
        if(sum==0)
            printf("0 0 0\n");
        else
            printf("%lld %d %d\n",sum,start,End);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值