How Many Tables
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
2
4
题意:第一个数是几组测试数据,对于每组测试数据来说,第一行n,m;
表示有n 个人,m组关系,接下来的m行a和b,就是说a和b认识;而且,朋友的朋友是朋友。互相认识的人在一张桌子上,问一共需要多少桌子?
并查集的知识,最后看看一共有多少祖先是自己的,就需要多少张桌子。
#include<iostream>
using namespace std;
int pre[1005],t,n,m,cnt;
int find(int x){
if(x==pre[x])
return x;
else return pre[x]=find(pre[x]);
}
void merge(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}
void init(){
cnt=0;
int x,y;
for(int i=1;i<=n;i++) pre[i]=i;
for(int i=1;i<=m;i++){
cin>>x>>y;
if(find(x)!=find(y)) merge(x,y);
}
}
int solve(){
for(int i=1;i<=n;i++){
if(pre[i]==i) cnt++;
}
return cnt;
}
int main(){
cin>>t;
while(t--){
cin>>n>>m;
init();
cout<<solve()<<endl;
}
return 0;
}