java.lang.VerifyError: class scala.collection.mutable.WrappedArray overrides final method(已解决)

java.lang.VerifyError: class scala.collection.mutable.WrappedArray overrides final method toBuffer.()Lscala/collection/mutable/Buffer;

出现这个原因是因为spark版本与scala-sdk版本不一致导致的

解决办法:首先找到和自己spark对应的scala-sdk版本,我的spark是2.1,因此对应2.11

image-20201025144032344

然后去官网下载对应的zip包

https://www.scala-lang.org/download/

image-20201025144220941

下载完成后解压到指定目录,我这里是

image-20201025144300702

然后打开idea的项目结构设置

image-20201025144518061

browse到你刚刚解压的目录

image-20201025144557932

添加成功后记得把上个版本删干净,有可能还有存留的依赖

image-20201025144642503

然后再次运行scala,成功

©️2020 CSDN 皮肤主题: 黑客帝国 设计师:上身试试 返回首页