PAT甲级1074 Reversing Linked List (25 分)

1074 Reversing Linked List (25 )

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (105) which is the total number of nodes, and a positive K (N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

      题目大意:

         给定一个单链表的起始地址,以及n个结点和每k位相反的位数。输出相反后的结果。

 

思路:

         将数据与下个结点的地址分开,都采用静态链表。然后用一个list装下有效结点。

         用数组能最快解决该问题。现在对第i个元素进行操作,反转后他的下标应当属于 i / k * k + k – 1 – i % k。 i / k * k 表明是第n块反转,如 I = 0 时, 应属于第一块(下标是 0 ~ k - 1)中。 K – 1 – i % k, 是反转后在该块中的位置(如 I = 0 时, 应当是 k – 1, I = 1 则应当为 k - 2 )。而如何确定该处理到哪呢?=》 由cnt – cnt % k即可知道,表示为list的长度减去余数,即不能整除的部分。  

参考代码:

 

#include<cstdio>
int ans[1000000], list[1000000], data[1000000], next[1000000];
int st, n, k, cnt;
int main(){
	scanf("%d%d%d", &st, &n, &k);
	for(int i = 0; i < n; ++i){
		int temp;
		scanf("%d", &temp);
		scanf("%d%d", &data[temp], &next[temp]);
	}
	while(st != -1){
		list[cnt++] = st;
		st = next[st];
	}
	for(int i = 0; i < cnt; ++i)	ans[i] = list[i];
	for(int i = 0; i < cnt - cnt % k; ++i)	ans[i] = list[i / k * k + k - 1 - i % k];
	for(int i = 0; i < cnt - 1; ++i)	printf("%05d %d %05d\n", ans[i], data[ans[i]], ans[i + 1]);
	printf("%05d %d -1", ans[cnt - 1], data[ans[cnt - 1]]);
	return 0;
}

代码参考:https://blog.csdn.net/liuchuo/article/details/51985857

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值