Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile)

1 篇文章 1 订阅

2019/4/24

问题描述
在创建和配置好maven项目之后进行Install,结果报错

Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile)

解决思路
该错误的是由maven版本引起的,这钟情况大多数是因为pom.xml文件没有设置设置相关版本信息。

解决方法

在plugins标签中添加maven版本信息,代码如下:

<plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
 </plugin>
  • 2
    点赞
  • 0
    评论
  • 2
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值