PAT A1092 To Buy or Not to Buy(同B1039)

PAT A1092 To Buy or Not to Buy(同B1039)

在这里插入图片描述

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2
  • 思路 1:
    遍历buy,在sold中find是否存在,存在就删除sold中对应字符,不存在cnt++,根据cnt的值输出结果

  • code 1:

#include <iostream>
#include <string>
using namespace std;

int main(){
	string sold, buy;
	cin >> sold >> buy;
	int cnt = 0;
	for(int i = 0; i < buy.size(); ++i){
		if(sold.find(buy[i]) != string::npos){
		//找到了,在sold中earse这个元素
			sold.erase(sold.find(buy[i]), 1); 
		}else{
		//没找到,统计缺几个 
			cnt++; 
		}
	}
	if(cnt == 0) cout << "Yes " << sold.size();
	else cout << "No " << cnt;
	return 0;
}
  • 思路2:散列

  • T2 code:

#include <bits/stdc++.h>
using namespace std;
int has[256];

int main(){
	string shop, eva;
	cin >> shop >> eva;
	for(int i = 0; i < shop.size(); ++i){
		has[shop[i]]++;
	}
	int miss = eva.size();
	for(int i = 0; i < eva.size(); ++i){
		if(has[eva[i]] > 0){
			miss--;
			has[eva[i]]--;
		}
	}
	if(miss == 0) printf("Yes %d", shop.size()-eva.size());
	else printf("No %d", miss);
	return 0;
} 

  • T3 code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 300;
int has[maxn];

int main()
{
    string shop, eva;
    cin >> shop >> eva;
    for(int i = 0; i < shop.size(); ++i)
    {
        has[shop[i]-'0']++;
    }
    int cnt = 0;
    for(int i = 0; i < eva.size(); ++i)
    {
        if(has[eva[i]-'0'] == 0)
        {
            cnt++;
        }else
        {
            has[eva[i]-'0']--;
        }
    }
    if(cnt == 0) printf("Yes %d", shop.size()-eva.size());
    else printf("No %d", cnt);
    return 0;
}

  • T4 code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 256;
int has[maxn];

int main()
{
    string shop, owner;
    cin >> shop >> owner;
    for(int i : shop) has[i]++;
    int cnt = 0;
    for(int i : owner)
    {
        if(has[i] == 0)
        {
            cnt++;
        }else
        {
            has[i]--;
        }
    }
    if(cnt > 0) printf("No %d", cnt);
    else printf("Yes %d", shop.size() - owner.size());
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值