Catch That Cow(广度优先搜索)

Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题目大意: 两个坐标n和k,问从n最少走几步可以到达k,其中n的走法只能有三种
1.前进一步
2.后退一步
3.前进到当前坐标两倍的位置

解答

非常经典的题目,学过算法的人一眼就就能看出来是bfs,而我用了半天dfs。。。
言归正传,如果k在n的前面,由于只能选择后退一步的走法才能到k所以答案就是n和k的差值。若k>n的话,用bfs解决:首先定义一个队列q用来记录当前所在坐标,定义一个vis数组用来记录当前坐标是否之前来过以及到达此坐标的最小步数,对于本代码,vis数组的大小要定义成2倍的坐标最大值,否则会出现RE错误,泪奔。。。。下面是AC的代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,k,vis[200000];
queue<int> q;
void bfs(){
	 q.push(n);
	 while(!q.empty()){
	 	int pos=q.front();
	 	q.pop();
	 	int npos;
	 	for(int i=1;i<=3;i++){
	 		if(i==1) npos=pos+1;
	 		else if(i==2) npos=pos-1;
	 		else npos=pos*2;
	 	    if(!vis[npos]&&npos>=0&&npos<=100000){    //注意此处:因为pos*2后可能会超过100000,所以vis数组定义大小时要 
		    vis[npos]=vis[pos]+1;                     //超过200000,否则执行此条语句会RE 
		    if(npos==k) return;
		    q.push(npos);	
		 }
		 }	 
	 }
	 return;
}
int main(){
	while(~scanf("%d%d",&n,&k)){ 
	memset(vis,0,sizeof(vis));
	while(!q.empty()) q.pop();
	if(n>=k)
	printf("%d\n",n-k);
	else{
		bfs();
		printf("%d\n",vis[k]);
    }
	}
	return 0;
}

希望自己的编程能力越来越强哈哈哈,有问题可以评论交流啊,一起讨论

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值