Error Correction

 有些量的初始化要放在循环中

题目描述

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property: 
1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt. 

输入

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

输出

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

样例输入

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

样例输出

OK
Change bit (2,3)
Corrupt

#include<iostream>
using namespace std;
 int main()
 {
	 int j, i,p[200][200], c, d, h;
	 while (cin >> h)
	 {
		 int m = 0, n = 0, a[200] = { 0 }, b[200] = { 0 };
		 if (h == 0)
			 return 0;
		 for (i = 0; i < h; i++)
			 for (j = 0; j < h; j++)
			 {
				 cin >> p[i][j];
				 a[i] += p[i][j];
				 b[j] += p[i][j];
			 }

		 for (i = 0; i < h; i++)
		 {
			 if (b[i] % 2 != 0)
			 {
				 d = i; n++;
			 }
			 if (a[i] % 2 != 0)
			 {
				 c = i; m++;
			 }
		 }
		 if (m == n && n == 0)
			 cout << "OK"<<endl;
		 else if (m == n && n == 1)
			 cout << "Change bit (" << c+1 << "," << d+1 << ")"<<endl;
		 else
			 cout << "Corrupt"<<endl;
	 }
	     return 0;
	 }

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值