PAT Advanced—1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:
The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.
At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.
Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry

思路:
  根据时间流逝,模拟排队过程

注意:

  1. 出现段错误,是由于队为空的时候pop了,得在pop之前判断队是否为空
  2. 在循环里使用cin,要注意cin能否全部被执行,不然会影响到后面的输入
  3. 考虑同时离去多个人,则这时候,可以多人同时入队
  4. 17点之前开始服务,无论什么时候结束,都可以服务

反思:
  以后调试代码的时候,如果逻辑没有问题,并且正确的输入,造成段错误,好好的检查一下代码有没有字母写错了,真的。。

代码:(C++)

#include<iostream>
#include<vector>
#include<queue>
#include<map>

using namespace std;

int main()
{
    int n,m,k,q,x,y;
    cin>>n>>m>>k>>q;
    vector<queue<int> > ques(n);  //n条队伍
    vector<int> qus(n,0); //队伍服务开始时间
    vector<int> in(k+1);
    int cu = 0;  //记录顾客数量
    map<int,int> cus; //记录顾客离去时间
    for(int i=1; i<=k; i++)
        cin>>in[i];
    for(int i=-m+1; i<540; i++) //先把队伍填满
    {
        y = 0; //记录此时有多少可以进的队列
        for(int j=0; j<n; j++)  //统计当前时间队伍的空闲情况
        {
            if(!ques[j].empty() && ques[j].front() == i)  //时间到了,就离开
                ques[j].pop();
            if(ques[j].size() < m)
                y++;
        }
        for(int j=0; j<y; j++)  //多人同时进入
        {
            int min_q = m;  //初始化队最大数量
            int site = -1; //记录位置,找出最短的队列及队列的时间
            for(int z=0; z<n; z++)
            {
                if(ques[z].size() < min_q)
                {
                    site = z;
                    min_q = ques[z].size();
                }
            }
            if(site != -1 && cu<k)  //如果找到了这条队列,则将该人员插入,并记录他的离去时间
            {
                cu++;
                if(qus[site] < 540)  //只有服务时间在17:00之前的才记录
                    cus[cu] = in[cu]+qus[site];
                qus[site] += in[cu];  //更新队伍时间,下一个人开始的时间
                ques[site].push(qus[site]);  //顾客入队
            }
        }
        if(cu == k) //算完了,可以提前跳出
            break;
    }
    for(int i=0; i<q; i++)
    {
        cin>>x;
        if(cus.find(x) != cus.end())
            printf("%02d:%02d\n",8+cus[x]/60, cus[x]%60);
        else
            printf("Sorry\n");
    }
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值