Fishing Master(贪心)

题解:就是思考一下需要的时间 :抓第一条鱼的时间+煮鱼的时间这是固定的,然后思考煮n-1 条鱼的时间

是不是可以抓n-1条鱼如果大于等于答案就是:抓第一条鱼的时间+煮鱼的时间

否则就是 用煮鱼的时间%m放入优先队列,抓第一条鱼的时间+煮鱼的时间+m-que.top(),重复n-1-num次。

Problem Description

Heard that eom is a fishing MASTER, you want to acknowledge him as your mentor. As everybody knows, if you want to be a MASTER's apprentice, you should pass the trial. So when you find fishing MASTER eom, the trial is as follow:

There are n fish in the pool. For the i - th fish, it takes at least ti minutes to stew(overcook is acceptable). To simplify this problem, the time spent catching a fish is kminutes. You can catch fish one at a time and because there is only one pot, only one fish can be stewed in the pot at a time. While you are catching a fish, you can not put a raw fish you have caught into the pot, that means if you begin to catch a fish, you can't stop until after k minutes; when you are not catching fish, you can take a cooked fish (stewed for no less than ti) out of the pot or put a raw fish into the pot, these two operations take no time. Note that if the fish stewed in the pot is not stewed for enough time, you cannot take it out, but you can go to catch another fish or just wait for a while doing nothing until it is sufficiently stewed.

Now eom wants you to catch and stew all the fish as soon as possible (you definitely know that a fish can be eaten only after sufficiently stewed), so that he can have a satisfying meal. If you can complete that in the shortest possible time, eom will accept you as his apprentice and say "I am done! I am full!". If you can't, eom will not accept you and say "You are done! You are fool!".

So what's the shortest time to pass the trial if you arrange the time optimally?

 

 

Input

The first line of input consists of a single integer T(1≤T≤20), denoting the number of test cases.

For each test case, the first line contains two integers n(1≤n≤105),k(1≤k≤109), denoting the number of fish in the pool and the time needed to catch a fish.

the second line contains n integers, t1,t2,…,tn(1≤ti≤109) ,denoting the least time needed to cook the i - th fish.

 

 

Output

For each test case, print a single integer in one line, denoting the shortest time to pass the trial.

 

 

Sample Input

 

2 3 5 5 5 8 2 4 3 3

 

Sample Output

23 11

Hint

Case 1: Catch the 3rd fish (5 mins), put the 3rd fish in, catch the 1st fish (5 mins), wait (3 mins), take the 3rd fish out, put the 1st fish in, catch the 2nd fish(5 mins), take the 1st fish out, put the 2nd fish in, wait (5 mins), take the 2nd fish out. Case 2: Catch the 1st fish (4 mins), put the 1st fish in, catch the 2nd fish (4 mins), take the 1st fish out, put the 2nd fish in, wait (3 mins), take the 2nd fish out.

Source

2019中国大学生程序设计竞赛(CCPC) - 网络选拔赛

#include<stdio.h>
#include<algorithm>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll; 
int a[100010];
priority_queue<int>que;
int main()
{
	 int t;
	 scanf("%d",&t);
	 while(t--)
	 {
	 	int n,m;
	 	scanf("%d%d",&n,&m);
	 	ll num=0;
	 	ll sum=0;
	 	int minn=inf;
	 	for(int i=0;i<n;i++)
	 	{
	 		scanf("%d",&a[i]);
	 		que.push(a[i]%m);
			 minn=min(a[i],minn);
			 num+=a[i]/m;
			 sum+=a[i];
		}
		num-=minn/m;
		if(num>=n-1)
		{
			printf("%lld\n",sum+m);
		}
		else
		{
			int w=n-1-num;
			sum+=m;
			while(w)
			{
				w--;
				sum+=m-que.top();
				que.pop();
			}
			printf("%lld\n",sum);
		}
		while(!que.empty()) que.pop();
	  } 

	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值