【HDU - 2642】【Stars】

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 2428    Accepted Submission(s): 1006


 

Problem Description

Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.

 

 

Input

The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.

 

 

Output

For each query,output the number of bright stars in one line.

 

 

Sample Input

 

5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200

 

 

Sample Output

 

1 0

 

 

Author

teddy

 

 

Source

百万秦关终属楚

 

题意:就是问在给定区域内,有多少点亮着的星星

解题思路:二维树状数组 实时更新和求和 利用矩形的计算方法,求出某个区域的值

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn  1009
using namespace std;




int sum[maxn][maxn];

int lowbit(int x)
{
	return x&-x;
}
int sm(int x,int y)
{
	int ans=0;
	for(int i=x;i>0;i-=lowbit(i))
		for(int j=y;j>0;j-=lowbit(j))
		{
			ans+=sum[i][j];
		}
	return ans;
}
void updata(int x,int y,int val)
{
	for(int i=x;i<=maxn;i+=lowbit(i))
		for(int j=y;j<=maxn;j+=lowbit(j))
		{
			sum[i][j]+=val;
		}
}
int  get_val(int i,int j)
{
	int ans= sm(i,j)-sm(i-1,j)-sm(i,j-1)+sm(i-1,j-1);
	return ans;
}
int main()
{
	int m;
	memset(sum,0,sizeof(sum));
	char s[5];
	int ans=0;
	cin>>m;
	int x1,y1,x2,y2;
	while(m--)
	{
		scanf("%s",s);
		if(s[0]=='B')
		{
			scanf("%d%d",&x1,&y1);
			x1++;
			y1++;
			if(get_val(x1,y1)==0)
				updata(x1,y1,1);	
		}	
		if(s[0]=='D')
		{
			scanf("%d%d",&x1,&y1);
			x1++;
			y1++;
			if(get_val(x1,y1)==1)
				updata(x1,y1,-1);
		}
		if(s[0]=='Q')
		{
			scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
			if(x1>x2) swap(x1,x2);
			if(y1>y2) swap(y1,y2);
			x1++,y1++,x2++,y2++;
			ans=sm(x2,y2)-sm(x1-1,y2)-sm(x2,y1-1)+sm(x1-1,y1-1);
			printf("%d\n",ans);
		}	
	}	
	return 0;
}

 

CSDN海神之光上传的代码均可运行,亲测可用,直接替换数据即可,适合小白; 1、代码压缩包内容 主函数:main.m; 调用函数:其他m文件;无需运行 运行结果效果图; 2、代码运行版本 Matlab 2019b或2023b;若运行有误,根据提示修改;若不会,私信博主; 3、运行操作步骤 步骤一:将所有文件放到Matlab的当前文件夹中; 步骤二:双击打开main.m文件; 步骤三:点击运行,等程序运行完得到结果; 4、仿真咨询 如需其他服务,可私信博主或扫描博客文章底部QQ名片; 4.1 博客或资源的完整代码提供 4.2 期刊或参考文献复现 4.3 Matlab程序定制 4.4 科研合作 功率谱估计: 故障诊断分析: 雷达通信:雷达LFM、MIMO、成像、定位、干扰、检测、信号分析、脉冲压缩 滤波估计:SOC估计 目标定位:WSN定位、滤波跟踪、目标定位 生物电信号:肌电信号EMG、脑电信号EEG、心电信号ECG 通信系统:DOA估计、编码译码、变分模态分解、管道泄漏、滤波器、数字信号处理+传输+分析+去噪(CEEMDAN)、数字信号调制、误码率、信号估计、DTMF、信号检测识别融合、LEACH协议、信号检测、水声通信 1. EMD(经验模态分解,Empirical Mode Decomposition) 2. TVF-EMD(时变滤波的经验模态分解,Time-Varying Filtered Empirical Mode Decomposition) 3. EEMD(集成经验模态分解,Ensemble Empirical Mode Decomposition) 4. VMD(变分模态分解,Variational Mode Decomposition) 5. CEEMDAN(完全自适应噪声集合经验模态分解,Complementary Ensemble Empirical Mode Decomposition with Adaptive Noise) 6. LMD(局部均值分解,Local Mean Decomposition) 7. RLMD(鲁棒局部均值分解, Robust Local Mean Decomposition) 8. ITD(固有时间尺度分解,Intrinsic Time Decomposition) 9. SVMD(逐次变分模态分解,Sequential Variational Mode Decomposition) 10. ICEEMDAN(改进的完全自适应噪声集合经验模态分解,Improved Complementary Ensemble Empirical Mode Decomposition with Adaptive Noise) 11. FMD(特征模式分解,Feature Mode Decomposition) 12. REMD(鲁棒经验模态分解,Robust Empirical Mode Decomposition) 13. SGMD(辛几何模态分解,Spectral-Grouping-based Mode Decomposition) 14. RLMD(鲁棒局部均值分解,Robust Intrinsic Time Decomposition) 15. ESMD(极点对称模态分解, extreme-point symmetric mode decomposition) 16. CEEMD(互补集合经验模态分解,Complementary Ensemble Empirical Mode Decomposition) 17. SSA(奇异谱分析,Singular Spectrum Analysis) 18. SWD(群分解,Swarm Decomposition) 19. RPSEMD(再生相移正弦辅助经验模态分解,Regenerated Phase-shifted Sinusoids assisted Empirical Mode Decomposition) 20. EWT(经验小波变换,Empirical Wavelet Transform) 21. DWT(离散小波变换,Discraete wavelet transform) 22. TDD(时域分解,Time Domain Decomposition) 23. MODWT(最大重叠离散小波变换,Maximal Overlap Discrete Wavelet Transform) 24. MEMD(多元经验模态分解,Multivariate Empirical Mode Decomposition) 25. MVMD(多元变分模态分解,Multivariate Variational Mode Decomposition)
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值