【HDU - 5912 】【Fraction】

题目:

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below: 
 

As a talent, can you figure out the answer correctly?

Input

The first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains only one integer n (n≤8n≤8). 

The second line contains n integers: a1,a2,⋯an(1≤ai≤10a1,a2,⋯an(1≤ai≤10). 
The third line contains n integers: b1,b2,⋯,bn(1≤bi≤10)b1,b2,⋯,bn(1≤bi≤10).

Output

For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer. 

You should promise that p/q is irreducible.

Sample Input

1
2
1 1
2 3

Sample Output

Case #1: 1 2


        
  

Hint

Here are the details for the first sample:
2/(1+3/1) = 1/2

        
题意:求解图中的表达是的最终结果,最后输出分子分母。

解题思路:不得不说,看了有一会才理解了图中的居然是个表达式,= = 为自己汗颜,看到这个表达式,不用想,必须会用到递推,因为上层表达式的分母必须要由下层的结果来计算,所以需要倒着推。

ac代码:

#include<bits/stdc++.h>
using namespace std;

int n;
int a[105];
int b[105];
int gcd(int a,int b)
{
	if(b==0)
		return a;
	return gcd(b,a%b);
}
int frac(int num)
{
	if(num==n-1)
		return 1.0*b[n-1]/a[n-1];
	else
		return 1.0*b[num]/(a[num]+frac(num+1));
}
int main()
{
	int t;
	cin>>t;
	int Case=0;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(int i=1;i<=n;i++)
			scanf("%d",&b[i]);
	//	cout<<frac(0)<<endl;		
		int tmp;
		int f=a[n],ff=1;
		for(int i=n-1;i>=1;i--)
		{
			tmp=a[i]*f+b[i+1]*ff;
			ff=f;
			f=tmp; 
		}
		ff=ff*b[1];//ff是只计算分子的值,for结束后f是分母的值。
		int k=gcd(ff,f);
		printf("Case #%d: %d %d\n",++Case,ff/k,f/k);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值