HDU-1845-Jimmy’s Assignment(无向图最大匹配模板)

探讨如何解决HDU-1845 Jimmy's Assignment问题,该问题要求在无向图中找到最大匹配数,其中双向边需同时匹配。示例输入和输出展示了算法的应用。
摘要由CSDN通过智能技术生成

题目

题意:给你一个无向图,求最大匹配。双向边都需要连起来,ans=maxmatch/2;

Sample Input

2
4
1 2
1 3
1 4
2 3
2 4
3 4
4
1 2
1 3
1 4
2 3
2 4
3 4

Sample Output

2
2

#include <map>
#include <cmath>
#include <iostream>
#include <cstring>
#define m(a,b) memset(a,b,sizeof a)
#define inf 0x3f3f3f3f
typedef long long ll;
typedef double  du;
using namespace std;
const int N=5000+5;
const int M=400+5;
const int INF=0x3f3f3f3f;
int head[N],mt[N];
int vis[N],tot;
struct Edge{int to,nex;}edge[N*3];
void add(int from,int to)
{
    edge[++tot]=(Edge){to,head[from]};head[from]=tot;
    edge[++tot]=(Edge){from,head[to]};head[to]=tot;
}
int find_path(int x)
{
    for(int i=head[x];i;i=edge[i].nex)
    {
        int y=edge[i].to;
        if(!vis[y])
        {
            vis[y]=1;
            if(!mt[y]||find_path(mt[y]))
            {
                mt[y]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        m(head,0),m(mt,0);
        tot=1;
        int n;
        scanf("%d",&n);
        int cnt=n*3/2;
        while(cnt--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            add(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            m(vis,0);
            if(find_path(i))
                ans++;
        }
        printf("%d\n",ans/2);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值