Legal or Not

HDU - 3342 

 

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

题意:给你一组数据,n表示有多少个人,m表示这n人中间有多少种关系,然后就是n个人中m个关系,a b,a表示师傅,b表示徒弟,而题目要求是判断给你这组数据中是否存在即是某个人的师傅,又是其徒弟的关系(也就是 a b,b a,那么a就即是b的徒弟又是师傅),几是否有回路和环,如果有的话就输出No,没有就输出Yes。

这是一个典型的拓扑排序的例题,很适合学习拓扑排序。可以将每个人看作一个结点,而每个人的师傅的个数则表示这个结点对应的入度。然后通过对每个结点进行遍历,依次找出入度为0的结点,将其拿出,并将其对应指向的结点的入度减1,如果不存在回路和环的话,每个点的入度最后都会被减为-1,所以最后只需遍历所有点的入度,如果存在入度不为-1的点,就说明有环或回路,输出No.

代码如下:

#include <bits/stdc++.h>
using namespace std;
const int MAXN=1e2+10;
int vis[MAXN];
int a[MAXN][MAXN];
int n,m;
void toposort(){
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			if(vis[j]==0){
				vis[j]--;
				for(int k=0;k<n;k++){
					if(a[j][k]==1){
						vis[k]--;
					}
				}
				break;
			}
		}
	}
	int l=0;
	for(int i=0;i<n;i++){
		if(vis[i]!=-1) l++;
	}
	if(l==0) printf("YES\n");
	else printf("NO\n");
}
int main(){
	int x,y;
	while(~scanf("%d %d",&n,&m)&&(n||m)){
		memset(a,0,sizeof(a));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<m;i++){
			scanf("%d %d",&x,&y);
			if(a[x][y]==0){
				a[x][y]=1;
				vis[y]++;
			}
		}
		toposort();
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值