POJ 1502 MPI Maelstrom (单源最短路径)

MPI Maelstrom

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12672 Accepted: 7799

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source

East Central North America 1996

Dijkstra迪杰斯特拉算法:邻接表实现 ,O(N+M)log(N)

#include <iostream>
#include <vector>
#include <string>
using namespace std;
typedef struct U{
	int v,w;
}U;
vector<U> e[101];
int dis[101],mark[101],inf=1e8;
int main(int argc, char *argv[]) {
	int n;
	cin>>n;
	string s;
	U u;
	for(int i=2;i<=n;i++){
		for(int j=1;j<i;j++){
			cin>>s;
			if(s.compare("x")){
				u.w=0;
				for(int k=0;k<s.length();k++)
					u.w=u.w*10+s[k]-'0';
				u.v=i; e[j].push_back(u);
				u.v=j; e[i].push_back(u);
			}
		}
	}
	for(int i=1;i<=n;i++)
		dis[i]=inf; 
	for(int i=0;i<e[1].size();i++)
		dis[e[1][i].v]=e[1][i].w;
	int least;
	for(int i=1;i<n;i++){
		least=inf;
		int p;
		for(int j=2;j<=n;j++){
			if(!mark[j] && dis[j]<least){
				p=j;
				least=dis[j];
			}
		}
		mark[p]=1;
		for(int i=0;i<e[p].size();i++)
			dis[e[p][i].v]=min(dis[e[p][i].v],least+e[p][i].w);
	}
	cout<<least<<endl; 
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值