POJ[2253] Arbitrage 【SPFA判断正环】

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input 

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output 

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input 

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output 

Case 1: Yes
Case 2: No

题目大意:

给定一些货币,以及这些货币之间的汇率,要求看能不能通过货币的兑换赚到比最初更多的钱。

分析:

一种货币可以看成图上的一个点,一个兑换方式就是图上两种货币之间的一个边。

注意这里的边是有向边。

考虑边的权值,A到B的权值为 V_A*R_A_B

要求最终的金额增加,即要在图中找到正环。这样,在正环中就总能实现套利。

这里采用SPFA判断正环。

具体解释见代码。

 

//#include <bits/stdc++.h>
#include <iostream>
#include <string>
#include <cstring>
#include <queue>
#include <map>
#include <cmath>
#include <vector>
#include <iomanip>

using namespace std;

const int maxn=1005;
const int INF=0x3f3f3f3f;

string names[35];
map<string,int> mp;

double dis[maxn];
int head[maxn];
int vis[maxn],times[maxn];

int ans;
int m,n,s;
double initv;

struct node{
    int u,v;
    double r;
    int next;
}edge[maxn];

void add(int u,int v,double r){
    edge[ans].u=u;
    edge[ans].v=v;
    edge[ans].r=r;
    edge[ans].next=head[u];
    head[u]=ans++;
}

bool spfa(int st){
    memset(vis, 0, sizeof(vis));
    memset(times, 0, sizeof(times));	//times数组记录顶点入队的次数 
    for(int i = 1; i<=n; i++)
        dis[i] = 0;				//初始化其他点的dis值为0

    queue<int> Q;
    Q.push(st);
    vis[st] = 1;
    dis[st] = 1;	//初始货币值为 1 
    while(!Q.empty()){
        int u = Q.front();
        Q.pop(); 
		vis[u] = 0;
        for(int i = head[u]; i!=-1; i = edge[i].next){	 
            int v = edge[i].v;
            if(dis[v] < dis[u]*edge[i].r){	//注意这里的松弛条件
                dis[v] = dis[u]*edge[i].r;
                if(!vis[v]){
                    Q.push(v);
                    vis[v] = 1;
                    if(++times[v]>n) return true;	//某一顶点入队超过 n次,则存在正环 
                }
            }
        }
    }
    return false;
}

int main(){
	int cas=0;
	while(cin>>n&&n){
		mp.clear();
		ans=0;
		++cas;
		memset(head,-1,sizeof(head));
		string tmp;
		int cnt=0;
		for(int i=1;i<=n;i++){
			cin>>tmp;
			names[++cnt]=tmp;
			mp[tmp]=cnt;	//这里将货币名称映射为整型数值 
		}
		cin>>m;
		string tmp1,tmp2;
		double rate;
		int index1,index2;
		for(int i=1;i<=m;i++){
			cin>>tmp1>>rate>>tmp2;
			index1=mp[tmp1];
			index2=mp[tmp2];
			add(index1,index2,rate);	//加入有向边 
		}
		if(spfa(1))  cout<<"Case "<<cas<<": "<<"Yes"<<endl;
		else  cout<<"Case "<<cas<<": "<<"No"<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值