Falling Leaves

这里写图片描述
Sample Input

BDHPY
CM
GQ
K
*
AC
B
$

Sample Output

KGCBDHQMPY
BAC

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 10000+5
using namespace std;
struct Tree{
    char value;
    Tree *l,*r;
}*my;
Tree *creat(char x){
    Tree *t=(Tree *)new Tree;
    t->l=NULL;
    t->r=NULL;
    t->value=x;
    return t;
}
Tree *join(Tree *s,char x){
    Tree *t=(Tree *)new Tree;
    if(s==NULL){
        t=creat(x);
        s=t;
    }
    else {
        if(x<s->value)
            s->l=join(s->l,x);
        else
            s->r=join(s->r,x);
    }
    return s;
}
void put(Tree *s){
    if(s==NULL)
        return ;
    else {
        printf("%c",s->value);
        put(s->l);
        put(s->r);
    }
    return ;
}
int main(){
    string s,t;
    s="";
    while(cin>>t){
        if(t=="*"){
            my=NULL;
            for(int i=s.length()-1;i>=0;--i)
                   my=join(my,s[i]);
            put(my);
            putchar('\n');
            s="";
            continue;
        }
        else if(t=="$"){
            my=NULL;
            for(int i=s.length()-1;i>=0;--i)
                   my=join(my,s[i]);
            put(my);
            putchar('\n');
            break;
        }
        else s+=t;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值