PAT 甲级 1021(Deepest Root )

题目要求

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 1 0 4 10^4 104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components

翻译

给出图,如果是树则输出最远节点,如果不是,输出有几个连通子图

代码

#include<iostream>
#include<vector>
#include<set>
using namespace std;
vector<int> v[10001];
vector<int> path;
int visited[10001];
set<int> ans;
int n;
int maxdepth=0;
//dfs找几个连通度
void dfs(int cur)
{
    if(visited[cur]) return;
    visited[cur]=1;
    for(int i:v[cur])
    {
        dfs(i);
    }
}
//dfs2找最深的节点
void dfs2(int cur,int depth)
{
    if(visited[cur]) return;
    visited[cur]=1;
    if(depth>maxdepth){
        path.clear();
        path.emplace_back(cur);
        maxdepth=depth;
    }
    else if(depth==maxdepth){
        path.emplace_back(cur);
    }
    for(int i:v[cur])
    {
        dfs2(i,depth+1);
    }
}

int main()
{
    int i,j,k;
    cin>>n;
    for(i=1;i<n;i++)
    {
        cin>>j>>k;
        v[j].emplace_back(k);
        v[k].emplace_back(j);
    }
    for(i=1;i<=n;i++) visited[i]=0;
    int cnt=0;
    for(i=1;i<=n;i++)
    {
        if(!visited[i])
        {
            cnt++;
            dfs(i);
        }
    }
    if(cnt>1){
        cout<<"Error: "<<cnt<<" components";
    }
    else{
        for(i=1;i<=n;i++) visited[i]=0;
        dfs2(1,0);
        for(int each:path) ans.insert(each);

        for(i=1;i<=n;i++) visited[i]=0;
        maxdepth=0;
        path.clear();
        dfs2(*ans.begin(),0);
        for(int each:path) ans.insert(each);

        for(int each:ans){
            cout<<each<<endl;
        }
    }
    system("pause");
}

思路

又是一道深度优先遍历的题目
先找到连通度,分情况讨论,如果是树也就是一个连通度的时候进行对最远节点的寻找,如果不是树则输出有几个连通度。
这里说一下是树的时候,先随便找一个起点找到离这个点最远的节点(可能不止一个),这个(些)点就是一部分最远节点,再随便选择其中一个作为起点,找离这个点最远的节点,由于可能会有重复,我们需要使用set来进行存储,最后再进行输出。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值