Power Strings(循环节)

题目链接:https://vjudge.net/problem/POJ-2406

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:求字符串是由最小循环节循环几次得到的

#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
char s[N];
int next[N];
void getnext(int len) {
	int j=-1;
	next[0]=-1;
	for(int i=1; i<len; i++) {
		while(j!=-1&&s[i]!=s[j+1])
			j=next[j];
		if(s[i]==s[j+1])
			j++;
		next[i]=j;
	}
}
int main() {
    int Case=0;
    while(~scanf("%s",s)){
    	if(s[0]=='.') break;
    	int len=strlen(s);
    	getnext(len);
        int x=len-(next[len-1]+1);//循环节
        if(len%x==0)
        printf("%d\n",len/x);
        else
        printf("1\n");   	
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值