UVA 679 Dropping Balls

题目描述 :

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball’s moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag’s current value at this node is false, then the ball will first switch this flag’s value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag’s value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right. For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag’s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag’s values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag’s values at node 1, node 2, and node 5 before it stops at position 10.
Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.
Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the I-th ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT. Please write a program to determine the stop position P for each test case. For each test cases the range of two parameters D and I is as below: 2 ≤ D ≤ 20, and 1 ≤ I ≤ 524288. Input Contains l + 2 lines. Line 1 l the number of test cases Line 2 D1 I1 test case #1, two decimal numbers that are separated by one blank ... Line k + 1 Dk Ik test case #k Line l + 1 Dl Il test case #l Line l + 2 -1 a constant ‘-1’ representing the end of the input file Output Contains l lines. Line 1 the stop position P for the test case #1 ... Line k the stop position P for the test case #k ... Line l the stop position P for the test case #l 

Output 
Contains l lines.

Line 1          the stop position P for the test case #1 
...          
Line k the stop position P for the test case #k 
...          
Line l the stop position P for the test case #l


Sample Input 

5
4 2
3 4
10 1
2 2
8 128
-1


Sample Output 
12
7
512
3
255

 

一棵满二叉树,从根节点到叶节点从左往右从上到下依次编号1,2,3。。。2的n次方-1。有若干小球依次下落,每一次经过一个节点就会改变内部的开关,进入时开关为真向右,假向左。问每次输入一定层数后第i个下落的小球最后所在叶节点的标号。

 

找规律,

1:每个节点的左子为2*i,右子为i*2+1;

2:某个节点有n个小球走过,n个小球会被分流到该节点的左子和右子处,显然若n为偶数,则左子右子各有n/2个小球经过,若n为奇数,左子n/2+1,右子n/2个。由此可根据小球序号推知每一个点经过的小球数和该小球的下落方向

 

注意:树有n层,小球只下落n-1次

 

 

 

 

 

#include <stdlib.h>
#include <stdio.h>
#include <iostream>
#include <queue>
#include <algorithm>
#include <string.h>

using namespace std;

int t;
int flag[1<<20];
int main()
{
    cin >> t;
    while(t--){
        int d,n;
        scanf("%d%d",&d,&n);

        int k=1;
        for(int i=0;i<d-1;i++){
            if(n%2){
                k=k*2;
                n=(n+1)/2;
            }
            else {
                k=k*2+1;
                n=n/2;
            }
        }

        printf("%d\n",k);
    }
    scanf("%d",&t);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值