HDU-3555-Bomb(数位DP)

Bomb

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500
 

Sample Output

0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

解题思路:

数位DP模板题呀。
过了这题可以看看我上一篇博客的题。
如出一辙,比那题还少了一层限制。
枚举时区分三种状态:
1、前面已经出现过13 记为状态2
2、前面没出现13但前一位是1 记为状态1
3、前面没出现13且前一位不是1 记为状态0
https://blog.csdn.net/qq_43461168/article/details/103330437

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define int long long
using namespace std;
int a[20];
int dp[20][5];

int dfs(int pos,int pre,int limit,int flag)
{
    if(pos == -1) return (flag == 2);
    if(!limit && dp[pos][flag] != -1) return dp[pos][flag];
    int up = limit ? a[pos] : 9;
    int tmp = 0;
    for(int i = 0 ;i <= up ; i ++)
    {
        tmp += dfs(pos-1,i,limit && a[pos] == i ,
                (flag == 2 ? 2 : ((pre == 4 && i == 9) ? 2 : (i == 4 ? 1 : 0) )  ));
    }
    if(!limit) dp[pos][flag] = tmp;
    return tmp;
}

int solve(int x)
{
    int pos = 0;
    while(x)
    {
        a[pos++] = x%10;
        x /= 10;
    }
    return dfs(pos-1,0,1,0);
}

signed main()
{
    int n,a,b;
    memset(dp,-1,sizeof(dp));
    cin>>n;
    while(n--)
    {
        cin>>a;
        cout<<solve(a)<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值