HDU-1080 Human Gene Functions

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

Alt

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14 
21 

Reference Code

#include <cstdio>
#include <cstring>
#include <algorithm>
const int maxn=100+3;
char str1[maxn],str2[maxn];
int dp[maxn][maxn];
int same(char ch1,char ch2){
    if (ch1==ch2) return 5*(ch1!='-');
    if (ch1>ch2) std::swap(ch1,ch2);
    if (ch1=='-'){
        if (ch2=='T') return -1;
        else if (ch2=='G') return -2;
        else if (ch2=='A') return -3;
        else if (ch2=='C') return -4;
    }
    else if (ch1=='A') return -1-(ch2=='G');
    else if (ch1=='C') return -2-(ch2=='G');
    else if (ch1=='G') return -2;
}
int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        int l1,l2;
        scanf("%d%s",&l1,str1+1);
        scanf("%d%s",&l2,str2+1);
        for (int i=1;i<=l1;++i) dp[i][0]=dp[i-1][0]+same(str1[i],'-');
        for (int i=1;i<=l2;++i) dp[0][i]=dp[0][i-1]+same(str2[i],'-');
        for (int i=1;i<=l1;++i)
            for (int j=1;j<=l2;++j){
                dp[i][j]=std::max(dp[i-1][j]+same(str1[i],'-'),dp[i][j-1]+same(str2[j],'-'));
                dp[i][j]=std::max(dp[i][j],dp[i-1][j-1]+same(str1[i],str2[j]));
            }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}

Tips

本题应该运用LCS(Longest Common Subsequence)算法。

一个序列,如果是两个或多个已知序列的子序列,且是所有子序列中最长的,则为最长公共子序列。一般的LCS问题都属于NP问题,都可以采用动态规划去解决。具体为:
对于两个序列 s t r 1 str_1 str1 s t r 2 str_2 str2,设二维数组 d p [ i ] [ j ] dp[i][j] dp[i][j] 表示 s t r 1 str_1 str1的第 i i i位和 s t r 2 str_2 str2的第 j j j位之前的最长公共子序列的长度,则有 d p [ 1 ] [ 1 ] = same ( 1 , 1 ) d p [ i ] [ j ] = max ⁡ ( d p [ i − 1 ] [ j − 1 ] + same ( i , j ) , d p [ i − 1 ] [ j ] , d p [ i ] [ j − 1 ] ) \begin{aligned}&amp;dp[1][1]=\text{same}(1,1)\\ &amp;dp[i][j] = \max(dp[i-1][j-1]+\text{same}(i,j),dp[i-1][j],dp[i][j-1])\end{aligned} dp[1][1]=same(1,1)dp[i][j]=max(dp[i1][j1]+same(i,j),dp[i1][j],dp[i][j1])其中 same ( i , j ) \text{same}(i,j) same(i,j)是判断 s t r 1 [ i ] str_1[i] str1[i] s t r 2 [ j ] str_2[j] str2[j]重合度的函数,可以是 1 , 0 1,0 1,0,也可以改成需要的函数,如本题中给出的表格。
d p [ i ] [ j ] dp[i][j] dp[i][j]中最大的数便是 s t r 1 str_1 str1 s t r 2 str_2 str2的最长公共子序列的长度。
该算法的空间、时间复杂度均为 O ( n 2 ) O(n^2) O(n2),经过优化后,空间复杂度可达到 O ( n ) O(n) O(n),时间复杂度可达到 O ( n log ⁡ n ) O(n\log n) O(nlogn)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值