PAT A1102 Invert a Binary Tree (25 分)(利用左右孩子结点信息建树后反转二叉树)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

此题输入的是结点的左右孩子信息,‘-’号代表没有此项,可以记为-1.由于此题输入的都是结点编号,固可用静态二叉树的写法实现。注意静态树的写法。

参考代码:

#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=110;
struct node{ //二叉树静态写法 
	int lchild;
	int rchild;
}Node[maxn];

bool notroot[maxn]={false}; //记录是否是根节点,初始均是根节点 
int n,num=0;//n为结点个数,num为当前已输出结点个数 
//print函数输出结点id的编号
void print(int id)
{
	printf("%d",id);
	num++;
	if(num<n)
		printf(" ");
	else
		printf("\n"); 
 } 
//中序遍历
void inorder(int root)
{
	if(root==-1)
		return;
	inorder(Node[root].lchild);
	print(root);
	inorder(Node[root].rchild);
 } 
//层次遍历 
void BFS(int root)
{
	queue<int> q; //注意队列里是存地址,此处是静态链表,存储int型 
	q.push(root);
	while(!q.empty())
	{
		int p=q.front();
		print(p);
		q.pop();
		if(Node[p].lchild!=-1) //左子树非空 
			q.push(Node[p].lchild);
		if(Node[p].rchild!=-1) //右子树非空 
			q.push(Node[p].rchild);	
	}
}
//后序遍历,用以反转二叉树
void postorder(int  root)
{
	if(root==-1)
		return;
	postorder(Node[root].lchild);
	postorder(Node[root].rchild);
	swap(Node[root].lchild,Node[root].rchild);//交换左右孩子结点 
 } 
//将输入的字符转换为-1或结点编号
int strToNum(char c)
{
	if(c=='-')
		return -1; //表示没有孩子结点,记为-1
	else
	{
		notroot[c-'0']=true; //标记c不是根节点
		return c-'0'; //返回结点编号 
	 } 
 }
 //寻找根节点编号 
int findroot()
{
	for(int i=0;i<n;++i)
	{
		if(notroot[i]==false)
			return i;   //是根节点,则返回i 
	 } 
 } 
int main()
{
	char lchild,rchild;
	scanf("%d",&n);
	for(int i=0;i<n;++i)
	{
		getchar(); //吸收换行符 
		//scanf("%*c%c %c",&lchild,&rchild);更好 %*c可在scanf中吸收一个字符,这样就可以将上行的换行符吸收掉 
		scanf("%c %c",&lchild,&rchild); //左右孩子结点 
		Node[i].lchild=strToNum(lchild);
		Node[i].rchild=strToNum(rchild); 
	}
	int root=findroot();//获得根节点编号
	postorder(root);//后序遍历,反转二叉树 
	BFS(root);
	num=0;
	inorder(root);
	return 0;	
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值