B - The Suspects 并查集,思路巧妙

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

大概题意:

严重急性呼吸综合征(SARS)是一种病因不明的非典型肺炎,2003年3月中旬被公认为全球威胁。为了尽量减少传染给他人,最好的策略是将嫌疑人与他人分开。              

在不扩散你的疾病大学(NSYSU),有许多学生团体。同一小组的学生经常互相交流,一个学生可以加入几个小组。为了防止可能的非典传播,NSYSU收集所有学生团体的成员名单,并在其标准操作程序(SOP)中制定以下规则。            

 一旦一个组中的成员是嫌疑犯,该组中的所有成员都是嫌疑犯。            

 然而,他们发现,当学生被认定为嫌疑犯时,要确定所有嫌疑犯并不容易。你的工作是写一个程序,找出所有嫌疑犯。            

 输入            

输入文件包含几个事例。每个测试用例以一行中的两个整数n和m开始,其中n是学生数,m是组数。您可以假设0<n<=30000和0<=m<=500。每个学生都由一个介于0和n−1之间的唯一整数进行编号,在所有情况下,最初的学生0都被视为嫌疑犯。这一行后面是M组成员列表,每组一行。每行以一个整数k开头,该整数本身表示组中的成员数。在成员数之后,有k个整数表示该组中的学生。一行中的所有整数都由至少一个空格分隔。              

n=0,m=0的情况表示输入结束,不需要处理。              

输出              

对于每种情况,输出一行中的嫌疑人数量。 

总的来说,只需要把输入的所有编码全部合并到一起,然后查找哪个集合里面有0这个编码,就可以了,但是我脑子抽了竟然分情况讨论有0的怎么合并,没有0的一组怎么合并。。。其实这里全部直接合并就好了

第二个点是查找含0编码那一集合里的人数,这里我们可以用累加法,先将每个人赋值为1,每合并一个,就将子节点所代表的值赋给根节点,最后输出0的根节点的值的大小就好了

贴个代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int dad[30010],sb[30010],sum[30010];
int find(int x)
{
    if(dad[x]!=x)
        dad[x]=find(dad[x]);
    return dad[x];
}
void join(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        dad[fx]=fy;
        sum[fy]+=sum[fx];  //赋值
    }
}
int main()
{
    int n,m,t;
    while(~scanf("%d %d",&n,&t)&&(n||t))
    {
        s.clear();
        for(int i=0; i<n; i++)  //初始化
        {
            dad[i]=i;  
            sum[i]=1;
        }
        memset(sb,0,sizeof(sb));
        for(int i=0; i<t; i++)
        {
            scanf("%d",&m);
            int x,y,flag=0;
            for(int j=0; j<m; j++)
            {
                scanf("%d",&sb[j]);
                join(sb[j],sb[0]);   //直接合并
            }
        }
        printf("%d\n",sum[find(0)]);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值