PTA甲级 1019 General Palindromic Number (C++)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 N>0 N>0 in base b ≥ 2 b≥2 b2, where it is written in standard notation with k + 1 k+1 k+1 digits a i a_i ai as ∑ i = 0 k ( a i b i ) ∑_{i=0}^k (a_ib^i) i=0k(aibi). Here, as usual, 0 ≤ a i < b 0≤a_i<b 0ai<b for all i and a k a_k ak is non-zero. Then N N N is palindromic if and only if a i = a k − i a_i =a_{k−i} ai=aki for all i i i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N N N and a base b b b, you are supposed to tell if N N N is a palindromic number in base b b b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N N N and b b b, where 0 < N ≤ 1 0 9 0<N≤10^9 0<N109 is the decimal number and 2 ≤ b ≤ 1 0 9 2≤b≤10^9 2b109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N N N is a palindromic number in base b b b, or No if not. Then in the next line, print N N N as the number in base b b b in the form “ a k a k − 1 . . . a 0 a_k a_{k−1} ... a_0 akak1...a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-12 13:05:08
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    int n, b, len = 0;
    bool isPali = true;
    cin >> n >> b;

    vector<int> radixB;

    while(n != 0){
        int shang = n / b;
        int yushu = n % b;

        radixB.push_back(yushu);
        len++;

        n = shang;
    }
    // radixB 里面是倒序

    for(int i = 0; i < len / 2; ++i){
        if(radixB[i] != radixB[len - i -1]){
            isPali = false;
            break;
        }
    }

    if(isPali) printf("Yes\n");
    else printf("No\n");

    for(int i = 0; i < len - 1; ++i) printf("%d ", radixB[len - i - 1]);
    printf("%d\n", radixB[0]);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值