PTA甲级 1050 String Subtraction (C++)

Given two strings S 1 S_1 S1 and S 2 S_2 S2, S = S 1 − S 2 S=S_1−S_2 S=S1S2 is defined to be the remaining string after taking all the characters in S 2 S_2 S2 from S 1 S_1 S1. Your task is simply to calculate S 1 − S 2 S_1 −S_2 S1S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S 1 S_1 S1 and S 2 S_2 S2, respectively. The string lengths of both strings are no more than 1 0 4 10^4 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S 1 − S 2 S_1−S_2 S1S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-18 13:48:04
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    unordered_map<char, int> map;

    string s1, s2;
    getline(cin ,s1);
    getline(cin ,s2);

    int len2 = s2.length();
    for(int i = 0; i < len2; ++i) map[s2[i]] = 1;

    for(int i = 0; i < s1.length(); ++i) 
        if(map[s1[i]] == 1) s1.erase(i--, 1);

    cout << s1 << endl;

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值