PTA甲级 1081 Rational Sum (C++)

Given N N N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N ( ≤ 100 ) N (≤100) N(100), followed in the next line N N N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

Caution:

注意【数据溢出】以及【求最大公约数】问题。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-22 21:40:27
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

long long gcd(long long a, long long b){
    if(a < b) swap(a, b);

    if(a % b == 0) return b;
    else return gcd(b, a % b);
}

struct Num{
    long long numerator;
    long long denominator;

    Num(long long n, long long d){
        numerator = n;
        denominator = d;

        if(n == 0) return;

        long long pos = gcd(abs(numerator), denominator);

        numerator /= pos;
        denominator /= pos;
    }

    ~Num(){}
};

Num add(Num &a, Num &b){
    long long numerator = a.numerator * b.denominator + b.numerator * a.denominator;
    long long denomiator = a.denominator * b.denominator;

    Num ans(numerator, denomiator);
    return ans;
}

int main(){
    int n;

    scanf("%d", &n);
    Num ans(0, 1);

    for(int i = 0; i < n; ++i){
        int numerator, denominator;

        scanf("%d/%d", &numerator, &denominator);
        Num tmp((long long)numerator, (long long)denominator);
        ans = add(ans, tmp);

    }

    long long integer, frational;
    integer = ans.numerator / ans.denominator;
    frational = ans.numerator % ans.denominator;

    if(integer == 0 && frational == 0) cout << 0 << endl;
    else if(integer == 0 && frational != 0) cout << frational << '/' << ans.denominator << endl;
    else if(integer != 0 && frational == 0) cout << integer << endl;
    else cout << integer << ' ' << frational << '/' << ans.denominator << endl;

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值