Monkey and Banana HDU - 1069-----dp(LIS)

第二天叫醒我的不是闹钟,是梦想!

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

//给你n个方块,三个属性长,宽,高且三个属性都可以交换。然后把这些方块搭起来是最高,上一层必须小于下一层,且要留出空间。这个就像最长下降子序列。
所以我们一个方块有3种样子,都要写出来。dp[i]:表示第i个矩形是最后一个,且高度最大。根据LIS dp[i]=max(dp[i],dp[j]+a[i].h)



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
const int N=1e6+100;
int n;
int f[N];
struct node
{
  int l,w,h,area;
}a[N];
int res[N];
bool cmp(const node &a,const node &b)
{
  if(a.area==b.area) return a.l>b.l;
  return a.area>b.area;
}
int main()
{
  int t=0;
    while(~scanf("%d",&n)&&n)
    {
      int k=0;
      memset(f,0,sizeof f);
      for(int i=1;i<=n;i++,k+=3)
      {
        cin>>res[1]>>res[2]>>res[3];
        sort(res+1,res+1+3);
        a[k].l=res[3];a[k].w=res[2];a[k].h=res[1];
        a[k].area=res[3]*res[2];

        a[k+1].l=res[3];a[k+1].w=res[1];a[k+1].h=res[2];
        a[k+1].area=res[3]*res[1];

        a[k+2].l=res[2];a[k+2].w=res[1];a[k+2].h=res[3];
        a[k+2].area=res[2]*res[1];
      }
      sort(a,a+k,cmp);
      int num=0;
      for(int i=0;i<3*n;i++)
      {
        f[i]=a[i].h;
        for(int j=0;j<i;j++)
            if(a[i].w<a[j].w&&a[i].l<a[j].l)
                f[i]=max(f[i],f[j]+a[i].h);
        num=max(num,f[i]);
      }
      printf("Case %d: maximum height = %d\n",++t,num);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值