poj 1007 DNA Sorting

14 篇文章 0 订阅
9 篇文章 0 订阅

Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted’’ to ``least sorted’’. All the strings are of the same length.
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from most sorted'' toleast sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source

package poj;

import java.util.ArrayList;//可变长列表,基于数组实现
import java.util.Collections;
import java.util.Iterator;
import java.util.List;
import java.util.Scanner;

class Main{
	
	static class Node implements Comparable{
		String str="";//输入字符串
		int id=0;//输入顺序号
		int sortN=0;//度量值
		
		Node(String str,int id,int sortN){
			this.str=str;
			this.id=id;
			this.sortN=sortN;
		}
		//-1 : 当前对象的值 < 比较对象的值 , 位置排在前
		//0 : 当前对象的值 = 比较对象的值 , 位置不变
		//1 : 当前对象的值 > 比较对象的值 , 位置排在后
		public int compareTo(Object o) {
			Node node=(Node)o;
			if(node.sortN==sortN){
				return node.id<id ? 1 : (node.id==id ? 0 : -1);
			}else {
				return node.sortN<sortN ? 1 : -1;
			}
		}
	}
	//返回一个字符串的度量值 measure(反转个数inversions)
	private static int getSortN(String str) {
		int len=str.length();
		int ans=0;
		for(int i=0;i<len;i++) {
			for(int j=i+1;j<len;j++) {
				if(str.charAt(i)>str.charAt(j))
					ans++;
			}
		}
		return ans;
	}
	
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		in.nextInt();
		int ncase=in.nextInt();
		List<Node> l=new ArrayList<Node>();
		for(int i=0;i<ncase;i++) {
			String str=in.next();
			l.add(new Node(str,i,getSortN(str)));
		}
		Collections.sort(l);//排序
		for(Iterator<Node> it=l.iterator();it.hasNext();) {
			System.out.println(it.next().str);
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值