练习4.2 平衡二叉树的根 (25 分)

练习4.2 平衡二叉树的根 (25 分)

将给定的一系列数字插入初始为空的AVL树,请你输出最后生成的AVL树的根结点的值。
输入格式:

输入的第一行给出一个正整数N(≤20),随后一行给出N个不同的整数,其间以空格分隔。
输出格式:

在一行中输出顺序插入上述整数到一棵初始为空的AVL树后,该树的根结点的值。
输入样例1:

5
88 70 61 96 120

输出样例1:

70

输入样例2:

7
88 70 61 96 120 90 65

输出样例2:

88

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

typedef struct node* AVLNode;
struct node{
AVLNode Left,Right;
int Data;
};
int GetHeight(AVLNode A){
if(!A) return 0;
else{
int L=GetHeight(A->Left);
int R=GetHeight(A->Right);
return L>R?(L+1):(R+1);
}
}
AVLNode SingleLeftRotation(AVLNode A){
AVLNode B=A->Left; //左单旋,顺时针,B是A的左,A的左是B的右,B的右是A
A->Left=B->Right;
B->Right=A;
return B;
}
AVLNode SingleRightRotation(AVLNode A){
AVLNode B=A->Right;//右单旋,B是A的右,A的右是B的左,B的左是A
A->Right=B->Left;
B->Left=A;
return B;
}
AVLNode DoubleLeftRightRotation(AVLNode A){
A->Left=SingleRightRotation(A->Left); //左右双旋,A的左go右单旋,返回A的左单旋
return SingleLeftRotation(A);

}
AVLNode DoubleRightLeftRotation(AVLNode A){
A->Right=SingleLeftRotation(A->Right); //右左双旋,A的右go左单旋,返回A的右单旋
return SingleRightRotation(A);

}
AVLNode Insert(AVLNode A,int x){
if(!A){ //A->malloc!!!
AVLNode A=(AVLNode)malloc(sizeof(struct node));
A->Data=x;
A->Left=A->Right=NULL;
return A;
}
else if(xData){
A->Left=Insert(A->Left,x);
if(GetHeight(A->Left)-GetHeight(A->Right)2){
if(xLeft->Data) A=SingleLeftRotation(A);
else A=DoubleLeftRightRotation(A);
}
}
else if(x>A->Data){
A->Right=Insert(A->Right,x);
if(GetHeight(A->Left)-GetHeight(A->Right)
-2){
if(x>A->Right->Data) A=SingleRightRotation(A);
else A=DoubleRightLeftRotation(A);
}
}
return A;
}
int main(){
int n,x;
AVLNode A=NULL; //!!!
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&x);
A=Insert(A,x);
}
printf("%d",A->Data);
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值