PAT甲级 1022 Digital Library

PAT甲级 1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 10 ​ 4 ) N (≤10​^4) N(104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title -- a string of no more than 80 characters;
Line #3: the author -- a string of no more than 80 characters;
Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher -- a string of no more than 80 characters;
Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

这题算是PAT甲级里面比较水的工程题了叭😀我一遍就过了
我一开始想用map一个key对应多个键值,结果要重构运算符,很麻烦,后来想想发现其实可以给每个字符串标号,用vector存储该序号对应的书的编号即可,查找时排序输出即可,非常简便快捷,注意读入带空格的字符串时要getchar(),具体注释见代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

map<string,int>m;
vector<string>q[100005];//存储对应标号下的书籍编号
int n,id=1,t;
string s,num,ss;

void judge(string s){//对字符串进行编号和存储
     if(!m[s]){
            m[s]=id;
            q[id].push_back(num);
            id++;
        }
    else q[m[s]].push_back(num);
}

int main()
{
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>num;
        getchar();//很关键,不能漏,因为getline会读入空格
        getline(cin,s);
        judge(s);
        getline(cin,s);
        judge(s);
        getline(cin,s);
        int p=-1,len=s.size();
        for(int i=0;i<len;i++){//存储关键词,逐个截取存储
            if(s[i]==' '){
                ss=s.substr(p+1,i-p-1);judge(ss);p=i;
            }
            if(i==len-1){
                string ss=s.substr(p+1,n-p-1);judge(ss);
            }
        }
        getline(cin,s);
        judge(s);
        getline(cin,s);
        judge(s);
    }
    cin>>t;
    for(int i=1;i<=t;i++){
        if(i==1) getchar();//很关键,不能漏,因为getline会读入空格
        getline(cin,s);
        cout<<s<<endl;
        s=s.substr(3,s.length()-3);
        if(m[s]==0) puts("Not Found");
        else{
            sort(q[m[s]].begin(),q[m[s]].end());//排序输出
            for(string ans:q[m[s]]) cout<<ans<<endl;
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺 崽

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值