(今天是两个舍友把我锁宿舍的一天,嘿,嘿嘿。。。。)1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

随着2010年国际足联世界杯的举办,世界各地的球迷越来越兴奋,因为他们是南非最好的球队中最优秀的球员,为争夺世界杯奖杯而战。同样,足球博彩迷们也把钱放在嘴边,下了各种各样的世界杯赌注。

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

中国足球彩票提供了“三连胜”游戏。获胜的规则很简单:首先选择三场比赛。然后,在每一场被选中的游戏中,押注三种可能的结果之一-W代表赢,T代表平局,L赌输。每个结果都有一个奇数。胜利者的奇数将是三次赔率乘以65%的乘积。

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

要获得最大的利润,必须购买W为第三局,T为第二局,T为第一局。如果每次投注2元,则最大收益为(4.1×3.1×2.5×65%−1)×2=39.31元(精确到小数点2位)。

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

对于每个测试用例,在一行中打印出每个游戏的最佳赌注,并将最高利润精确到小数点后2位。字符和数字必须用一个空格分隔。

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

 

#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
	char c[4] = { "WTL" };//定义一个字符串数组!!!
	double ans = 1;
	for (int i = 0; i < 3; i++)
	{
		double maxvalue = 0;
		int maxchar = 0;
		for (int j = 0; j < 3; j++)
		{
			double temp;
			cin >> temp;//输入一行
			if (maxvalue <= temp)//找最大的数
			{
				maxvalue = temp;
				maxchar = j;//标记位置
			}
		}
		ans *= maxvalue;//最大值累乘
		cout << c[maxchar] << " ";//每一行对应一个字符输出
	}
	printf("%.2f", (ans*0.65 - 1) * 2);//套公式
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值