AS:Error:(27, 13) Failed to resolve: com.android.support:appcompat-v7:30.+解决办法

AS:Error:(27, 13) Failed to resolve: com.android.support:appcompat-v7:30.+解决办法

在这里插入图片描述
刚刚开始入门第一个AS项目就给我来一个这个报错,搞了一天终于搞好了。

首先打开SDK Manager:
在这里插入图片描述
查看自己的sdk tools版本:(26.1.1)
在这里插入图片描述
再查看sdk构建工具的版本,我好像有两个构建工具的版本这里没有显示出来
在这里插入图片描述
在这里插入图片描述
然后回到app的build.gradle文件中:
在这里插入图片描述
把对应的30改成26:
在这里插入图片描述
在这里插入图片描述
然后clean一下就好了:
在这里插入图片描述

©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页