Big Event in HDU
题目来源:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1004&ojid=0&cid=13029&hide=0
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
题目大意:对于每种情况,打印一行包含两个整数A和B,分别表示计算机学院和软件学院的价值。A和B应尽可能相等。同时,你应该保证A不低于B.
题解:多重背包,几个典型的背包要会使用,,,自我感觉有点难,copy 别人的哈哈哈,拼命理解中ingining
代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=250020;
int dp[maxn];
int nValue;
///01背包,代价cost,价值weight
void ZeroOnePack(int cost,int weight)
{
for(int i=nValue; i>=cost; i--)
{
dp[i]=max(dp[i],dp[i-cost]+weight);
}
}
///完全背包
void CompletePack(int cost,int weight)
{
for(int i=cost; i<=nValue; i++)
{
dp[i]=max(dp[i],dp[i-cost]+weight);
}
}
///多重背包
void MultiplePack(int cost,int weight,int amount)
{
if(cost*amount>=nValue)
{
CompletePack(cost,weight);
}
else
{
int k=1;
while(k<amount)
{
ZeroOnePack(k*cost,k*weight);
amount-=k;
k<<=1;
}
ZeroOnePack(amount*cost,amount*weight);
}
}
int a[55],b[55];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n<0)
break;
nValue=0;
for(int i=0; i<n; i++)
{
cin >> a[i] >> b[i];
nValue+=a[i]*b[i];
}
memset(dp,0,sizeof(dp));
for(int i=0; i<n; i++)
{
if(b[i]==1)
ZeroOnePack(a[i],a[i]);
else
MultiplePack(a[i],a[i],b[i]);
}
int t=nValue/2;
while(dp[t]!=t)
t--;
printf("%d %d\n",nValue-t,t);
}
return 0;
}