HDU - 2101 A + B Problem Too【水题】

A + B Problem Too

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21290 Accepted Submission(s): 15584

Problem Description
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input
1 1
8600 8600

Sample Output
no
yes

Source
HDU 2007-6 Programming Contest

Recommend
xhd

问题链接:https://vjudge.net/problem/HDU-2101。

问题简述:输入两个整数,若这两个整数之和能被86整除,则输出“yes”,否则输出“no”。

问题分析:利用while循环输入,判断该两个整数之和能否被86整除即
if ((a+b) % 86 == 0),用 if-else 语句分别输出两种情况的不同输出结果。

程序说明:利用while循环,判断,利用 if-else 语句。

AC通过的C语言程序如下:

#include <iostream>
using namespace std;

int main()
{
	int a;
	int b;
	while (cin >> a >> b)
	{
		if ((a+b) % 86 == 0)
		{
			cout << "yes" << endl;
		}
		else
		{
			cout << "no" << endl;
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值