HDU-2141(Can you find it?)

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

题目大意

有一系列的a,b,c集合元素,输入一些数判断是否能等于a,b,c中各选一个元素相加和
能的话输出YES否则输出NO

AC代码

#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;
int aa[500],bb[500],cc[500],dd[250010];
int main()
{
    int a,b,c,x;
    int num=0;
    while(~scanf("%d %d %d",&a,&b,&c))
    {
        int e=0;
        for(int i=0; i<a; ++i)
            scanf("%d",&aa[i]);
        for(int i=0; i<b; ++i)
            scanf("%d",&bb[i]);
        for(int i=0; i<a; ++i)
            for(int j=0; j<b; ++j)
                dd[e++]=aa[i]+bb[j];
        for(int i=0; i<c; ++i)
            scanf("%d",&cc[i]);
        sort(dd,dd+e);
        scanf("%d",&x);
        ++num;
        printf("Case %d:\n",num);
        while(x--)
        {
            int ans,y;
            scanf("%d",&y);
            int p=0;
            for(int i=0; i<c; ++i)
            {
                ans=y-cc[i];
                int left=0,right=e-1,mid;
                while(left<=right)
                {
                    mid=(left+right)/2;
                    if(dd[mid]==ans)
                    {
                        printf("YES\n");
                        p=1;
                        break;
                    }
                    else if(dd[mid]<ans)
                    {
                        left=mid+1;
                    }
                    else if(dd[mid]>ans)
                    {
                        right=mid-1;
                    }
                }
                if(p==1)
                    break;
            }
            if(p==0)
                printf("NO\n");
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值