PAT (Basic Level) 1032 挖掘机技术哪家强 (20分)JAVA解法

在这里插入图片描述

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

import java.util.HashMap;
import java.io.IOException;
import java.io.BufferedReader;
import java.io.InputStreamReader;
public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
		int number = Integer.parseInt(bf.readLine().replace("\\s+", "")), max = 1, temp = 1;
		HashMap<Integer,Integer> map = new HashMap<>();
		for(int i = 0; i < number; i ++) {
			String[] str = bf.readLine().split("\\s+");
			if(!map.containsKey(Integer.parseInt(str[0]))) {
				map.put(Integer.parseInt(str[0]), Integer.parseInt(str[1]));
			} else {
				map.put(Integer.parseInt(str[0]), (map.get(Integer.parseInt(str[0])) + Integer.parseInt(str[1])));
			}
		}
		bf.close();
		while(map.containsKey(temp)) {
			if(map.get(max) < map.get(temp)) {
				max = temp;
			}
			temp ++;
		}
		System.out.println(max + " " + map.get(max));
	}
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值