矩形面积相交问题

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

=======================================================================================

#include<stdio.h>
#include<stdlib.h>
#include<math.h>//fabs头文件,别忘写,返回值double
int cmp(const void *a,const void *b)//const表示把当前类型转换为适用类型
{
    return *(double *)a>*(double *)b? 1:-1;//double类型排序略有不同
} 
int main()
{
     double x1,y1,x2,y2,x3,y3,x4,y4;
   while(~scanf("%lf %lf %lf %lf %lf %lf %lf %lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4))
   {
       double m,n,area;

       double a[4]={x1,x2,x3,x4};
       double b[4]={y1,y2,y3,y4};
       qsort(a,4,sizeof(a[0]),cmp);//sizeof表示取字节数
       qsort(b,4,sizeof(b[0]),cmp);

       m=fabs(x1-x2)+fabs(x3-x4)-(a[3]-a[0]);//该思想的精髓在于取其长度的投影,看是否有重叠的部分
       n=fabs(y1-y2)+fabs(y3-y4)-(b[3]-b[0]);

       if(n<0||m<0) area=0.0;
       else
         area=n*m;
        printf("%.2lf\n",area);


   }

       return 0;


}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值