F

9 篇文章 0 订阅

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

    Input
    The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

    Output
    For each test case, you must output the smallest times of typing the key to finish typing this string.

    Sample Input
    3

Pirates
HDUacm
HDUACM

    Sample Output
    8

8
8

    Hint
    The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.

The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

#include<stdio.h>
#include<string.h>
int main()
{
    int t,ans,da,i;
    char a[2050];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        ans=0;
        da=0;
        for(i=0; a[i]!=0; i++)
        {
            if(a[i]>='A'&&a[i]<='Z'&&a[i+1]>='A'&&a[i+1]<='Z'&&da==0)//如果连续两个大写 就转成大写的
            {
                da=1;
                ans++;
            }
            if(a[i]>='a'&&a[i]<='z'&&((a[i+1]>='a'&&a[i+1]<='z')||a[i+1]==0)&&da==1)//连续两个小写的就转成大写的
                //注意:如果已经是最后一个的话,就要转换成小写,这样最后可以少一步转换回小写的操作;
            {
                da=0;
                ans++;
            }
            if(a[i]>='A'&&a[i]<='Z')
            {
                if(da==0)
                {
                    ans+=2;
                }
                else
                {
                    ans++;
                }
            }
            else if(a[i]>='a'&&a[i]<='z')
            {
                if(da==0)
                {
                    ans++;
                }
                else
                {
                    ans+=2;
                }
            }
        }
        if(da)
        {
            ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

#include <iostream>
#include <bits/stdc++.h>
#include <string.h>
using namespace std;
int main()
{
    int a,sum,f,i,len;
    char s[2050];
    cin >> a;
    while(a--)
    {
        cin >> s;
        sum=0;
        f=0;
        len=strlen(s);
        for(i=0; i<len; i++)
        {
            if(s[i]>='A'&&s[i]<='Z'&&s[i+1]>='A'&&s[i+1]<='Z'&&f==0)
            {
                f=1;
                sum++;
            }
            if(s[i]>='a'&&s[i]<='z'&&((s[i+1]>='a'&&s[i+1]<='z')||s[i+1]==0)&&f==1)
            {
                f=0;
                sum++;
            }
            if(s[i]>='A'&&s[i]<='Z')
            {
                if(f==0)
                {
                    sum=sum+2;
                }
                else
                {
                    sum++;
                }
            }
            else if(s[i]>='a'&&s[i]<='z')
            {
                if(f==0)
                {
                    sum++;
                }
                else
                {
                    sum=sum+2;
                }
            }
        }
        if(f==1)
        {
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[100005];
int dpon[1005];
int dpoff[1005];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%s",a);
        memset(dpon,0,sizeof(dpon));
        memset(dpoff,0,sizeof(dpoff));
        int len=strlen(a);
        dpon[0]=1;
        dpoff[0]=0;
        for(int i=0;i<len;i++)
        {
            if(a[i]>='a'&&a[i]<='z')
            {
               dpon[i+1]=min(dpon[i]+2,dpoff[i]+2);
               dpoff[i+1]=min(dpon[i]+2,dpoff[i]+1);
            }
            else
            {
               dpon[i+1]=min(dpon[i]+1,dpoff[i]+2);
               dpoff[i+1]=min(dpon[i]+2,dpoff[i]+2);
            }
        }
        dpon[len]++;
         cout<<min(dpon[len],dpoff[len])<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值